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This exercise includes two hands-on-labs. 
 
HOL 6-1: Using an Interactive Report: In this lab, you customize and use an interactive report as 
an end user. 
  
HOL 6-2: Customizing an Interactive Report as a Developer: In this lab, as a developer, you 
customize an interactive report for your end users. 
 
Both these hands-on-labs utilize the Hardware application that you created in HOL 5-2. 
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HOL 6-1: Using an Interactive Report 

1. First, you run the Hardware application. To do this, navigate to Application Builder. In the 
report, click the Run button for Hardware. 

 
 

2. In the navigation menu, click Hardware Interactive Report. 
 

3. You do not want to display the Id and Form Factor columns in the report. Also, you want the 
Purchase Date column to display just before the Purchase Price column. Perform the following 
steps: 
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a) Click Actions and select Columns. 

 
b) The Select Columns dialog appears. The columns on the right are displayed, and the 

columns on the left are hidden. Select Id and Form Factor in Display in Report group, and 
click the Remove icon. 
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c) You can reorder the displayed columns using the arrows on the far right. Select Purchase 
Date in the Display in Report group, and click the Down arrow twice. Then, click Apply. 

 
d) The changes you made to the interactive report display are reflected now. 

 
 

4. You want to create filters on the report. First, you want to filter the report to display rows which 
meet the criteria Purchase Price >= 5330. Within these filtered results, you then create another 
filter to display rows with Cpu Type is Pentium III. Perform the following steps: 
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a) Click Actions and select Filter. 

 
b) For Filter Type, select Column. 

For Column, select Purchase Price, for Operator, select >= and select 5330 from the 
Expression list. 
Notice that this list of values for Expression is determined automatically, based on all the 
values in the Purchase Price column. 
Then, click Apply. 

 
c) The filter is applied now. You can have more than one filter on a report. If you decide that 

you want to disable a particular filter, you can click the check box to disable the filter. 
In this lab, you want to add another filter on the Cpu Type column.  
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Click the Actions menu, and select Filter. 

 
d) Select Cpu Type for Column, select = for Operator and select Pentium III from the 

Expression list.  
Click Apply. 

 
e) Notice that two filters are applied now. The rows displayed are fewer now because they are 

only the rows that meet both the filter criteria. You can remove each filter by clicking the 
Remove Filter icon, next to the filter you want to remove.  
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Click the Remove Filter icon next to both the filters. 

 
 

5. Both the filters are now removed, and you see that all the rows are displayed. You can also 
create a row filter.  
a) Click Actions, and select Filter. 

 
b) You want to create a filter which selects a row when both the following conditions are true:  

Cpu Type = 'Pentium III'  
Purchase Price >= 5330  
Select Row for Filter Type. 
Click Cpu Type under Columns and then click = from Functions / Operators. Enter 
'Pentium III'. 
Click AND under Functions / Operators. Click Purchase Price under Columns and then 
click >= under Functions / Operators. Enter 5330. 
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Click Apply. 
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c) The row filter is applied now. Click the Remove Filter icon to remove the filter. 

 
 

6. You want to sort the report on the Purchase Price column. 
a) Select Actions > Data > Sort. 
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b) Select Purchase Price for Column and click Apply. 

 
c) The report is now sorted in the ascending order of Purchase Price.  

Note: The sort indicator is located next to the columns that are sorted.  
The arrow indicates whether it is in ascending or descending order. To change the sort to 
descending order, you can click on the sort ascending icon in the header for Purchase Price 
and it will change to sort descending. 

 
 

7. Create an aggregation against the Purchase Price column. You want to display the sum of the 
purchase price. 
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a) Select Actions > Data > Aggregate. 

 
b) In the Aggregate dialog, select Sum for Function, Purchase Price for Column. Click Apply. 
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c) The aggregate function is applied on the column. Notice that the sum of purchase price is 
displayed at the end of the report under the column. 

 
 

8. In the report, you want to include purchase price calculated with tax. The computation you want 
to make is Purchase Price * 1.05. You create a computed column in the interactive report. 
a) Select Actions > Data > Compute. 

 
b) The Compute dialog appears.  

For Column Heading, enter Price with Tax and select $5,234.10 for Format Mask. 
For Computation Expression, click Purchase Price under Columns. Click *1.05 under 
Keypad. 
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Click Apply. 
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c) The new computed column Price with Tax now appears in the report. 

 
 

9. Create a Control Break on the Cpu Type column. 
a) Select Actions > Format > Control Break. 
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b) In the Control Break dialog, select Cpu Type for Column, and click Apply. 

 
c) The control break is applied now. Notice that the aggregation that you created in a previous 

step appears at the end of each control break. 

 
 

10. You want to highlight those rows with Price with Tax values less than $2300. You add the 
highlighting to rows while continuing with the control break that you created in the previous 
step. 
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a) Select Actions > Format > Highlight. 

 
b) In the Highlight dialog, enter Price with Tax less than $2400 for Name. 

Select yellow for Background Color and red for Text Color. 
For Highlight Condition: Select **Price with Tax column, and < Operator. Enter 2400 for 
Expression. 
Click Apply. 
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c) Notice that the rows that meet the condition are highlighted now. 

 
 

11. In your interactive report, you want to include a Chart to display the total Price with Tax for 
each Cpu Type. Your interactive report should include both the Report and Chart views to 
toggle. 
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a) Select Actions > Chart. 

 
b) In the Chart dialog, select / enter the following: 

 Chart Type: Horizontal Column 

 Label: Cpu Type 

 Value: **Price with Tax 

 Function: Sum 

 Axis Title for Label: Cpu Type 

 Axis Title for Value: Price with Tax 
Click Apply. 
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c) The chart is created. Toggle between the View Chart and View Report. 

 
d) You want to remove the control break and the highlighting. Click the X icon for both the 

filters. 

 
 

12. Create a Group By report to display each Cpu Type with the total purchase price. 
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a) Select Actions > Group By. 

 
b) In the Group By dialog enter / select: 

 Group By Column: Cpu Type 

 Function: Sum 

 Column: Purchase Price 

 Label: Total Price 

 Format Mask: $5,234.10 
Select the Sum check box and click Apply. 
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c) The Group By report is created. You also see the sum of the purchase price. Notice that the 
icon for View Group By is also added. 

 
d) Click the X to the right of Edit Group By to remove the filter. 
 

13. You want to display the count of each Cpu Type that are available with each department. The 
results should be in a crosstab format. Create a Pivot Report. 
a) Click Actions > Pivot. 

 
b) In the Pivot dialog enter / select: 

 Pivot Column: Cpu Type 
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 Row Column: Department Id 

 Functions: Count 

 Column: Cpu Type 
Click Apply. 

 
c) The Pivot report is displayed and a View Pivot icon is created. 

 
 

14. You want to save the report with all the customization. 
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a) Select Actions > Report > Save Report. 

 
b) Enter My Report for Name and click Apply. 
 

15. A drop down list automatically appears with the report you just created being selected. You can 
view the default primary report.  
You want to reset the Primary Report back to the default settings and remove any 
customizations that you have made so far. 
a) Select Primary Report from the Reports drop down list. The primary report is now 

displayed. You can make any changes to this report and it will not be reflected in the 'My 
Report' private report you just created. 
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b) Select Actions > Reset. 

 
c) In the Reset dialog, click Apply. 

 
d) From the Reports drop down list, select My Report.  

 
 

16. You want to download the customized report as a CSV. 
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a) Select Actions > Download. 

 
b) In the Download dialog, select CSV. 
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c) The report is now downloaded as a CSV. 

 
 

17. You want to make some more customization to your interactive report. From the Reports drop 
down list, select Primary Report. 

 
 

18. To customize the report, you now use the column heading menu instead of using the Actions 
menu. The report is currently sorted in ascending order of Purchase Price. You want to the 
report to be sorted in the descending order of Department Id. 
a) Click the Department Id header and select Sort Descending. 
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b) The report is now sorted in the descending order of Department Id. 

 
 

19. You do not want the Id and Form Factor columns in the report. 
a) Click the Id header and select Hide Column. 
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b) Click the Form Factor header and select Hide Column. 

 
c) Your report now looks like: 

 
 

20. Create a control break on the Department Id. 
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a) Click the Department Id header and select Control Break. 

 
b) The control break is now applied. 

 
 

21. You want to save the customizations made from step 18 through 20. You save the report as a 
Named Report. 
a) Select Actions > Report > Save Report. 
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b) The Save Report dialog appears. For Save, select As Named Report and enter 
Departments Hardware Report for Name. Click Apply. 

 
c) The report is saved and is now available in the Reports drop down list. 

 
 

22. You want to reset the primary report to default settings now. 
a) From the Reports down list, select Primary Report. 
b) Select Actions > Report > Reset. 
c) In the Reset dialog, click Apply. 
d) The primary report is now restored to default settings. The customizations you made to your 

private reports are available. 
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HOL 6-2: Customizing an Interactive Report as a Developer 

In this lab, you edit an interactive report in page designer and customize it for end users. 
 
1. First, view the interactive report in page designer. In the Developer Toolbar, click Edit Page 2. 

 
 

2. You do not want the Id and Form Factor columns to be displayed in the interactive report for 
end users. Modify the report source query. 
a) In the page designer, under Rendering > Regions, select Hardware Interactive Report. 

In the property editor, locate Source > SQL Query. 
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b) Copy and paste the following SQL in to SQL Query. 
 
select SERIAL, 

       CPU_TYPE, 

       CPU_SPEED, 

       PURCHASE_DATE, 

       BRAND, 

       MODEL, 

       PURCHASE_PRICE, 

       DEPARTMENT_ID 

  from HARDWARE 
c) Click Save. Then, click Save and Run Page. 
d) Your interactive report now looks like: 

 
 

3. When the end users click an edit icon for a specified row, they should be directed to a page 
which shows the column values for that row. The interactive report currently does not have a 
link column. Modify your interactive report to have a link to single row view. 
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a) Under Rendering, navigate to Hardware Interactive Report and select Attributes. 
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b) The attributes are now listed in the property editor. Under Link, for Link Column, select 
Link to Single Row View. Click Save. Then, click Save and Run Page. 

 
c) In the report, click the edit icon (pencil) for any row. 
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d) The single row view is displayed. Click Report View button to return to the report. 

 
 

4. The current pagination type of the interactive report is Row Ranges X to Y. You want this to be 
changed for the end users’ display of the report. 
Under Rendering, navigate to Hardware Interactive Report and select Attributes. 
In the property editor, locate Pagination. For Type, select Row Ranges X to Y of Z. 

 
 

5. You want to customize the display of Search Bar. End users should be able to select the display 
of desired number of rows per page.  
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In the property editor, locate Search Bar. For Rows Per Page Selector, select Yes. 
Enter 10 for Maximum Rows Per Page. 

 
 

6. Currently your interactive report allows end users to save the report as private. However, you 
also want to make sure that they can save a report as public. Enable this option in the Actions 
menu. 
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In the property editor, locate Actions Menu. For Save Public Report, select Yes. 

 
 

7. You want to disable the Email and RTF formats in the Download option of the Actions menu. 
In the property editor, navigate to Download. Deselect Email and RTF download formats. 

 



Oracle Application Express: Developing Database Web Applications 

 

40 
 

8. Now that you finished the customization for end users, click Save. Then, click Save and Run 
Page. 
 

9. Notice that the row selector and the new pagination type are available on the report. 

 
 

10. Select Actions > Report > Save Report. 
 

11. The Save Report dialog displays. Notice that the Public check box is now available.  
For Save, select As Named Report, enter Departments Public Report for Name. Select the 
Public check box and click Apply. 
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12. This report is now saved as a public report and is available in the Reports drop down list. 

 
 

13. Click Actions > Download. 
 

14. Notice that the Email and RTF formats are no longer available. Click Cancel. 

 
 

15. From the Reports drop down list, select Primary Report. 
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